Créer  Editer  FrontPage  Index  Chercher  Changements  History  RSS  Login

Guide Installation Windows

Guide d'installation pour Microsoft Windows (mswin32, mingw32)

Note

  • L'installation devrait se dérouler rapidement et aisément. Les paquetages nécessaires (pour le minimum requis) sont Ruby, Ruby/GTK2 et les binaires GTK2 pour Microsoft Windows Dropline.
  • Le paquetage Ruby-GNOME2 entier n'est pas encore supporté sur Microsoft Windows. Il ne le sera probablement jamais, vu qu'il est basé sur GNOME2.
  • Nous avons séparé les différentes versions de Microsoft Windows en deux catégories: Win9X/ME et WinNT/2000/XP/2003.
  • Ce processus d'installation a été testé avec Ruby 1.8, mais il devrait toutefois également fonctionner avec la version 1.6.

Etapes

Première étape

Deuxième étape

Troisième étape

Quatrième étape

  • Nous avons suffisament téléchargé, il est maintenant temps de tout configurer. En fait, il suffit juste de modifier une variable d'environnement, afin de rajouter le chemin vers les répertoires ou nous venons d'installer à l'instant les programmes.
  • Nous utiliserons ici les conventions suivantes:
    • ruby-install-dir pour le répertoire ou Ruby a été installé (Par exemple, C:\Ruby).
    • gtk-install-dir pour le répertoire ou GTK+2 a été installé (Par exemple, C:\Gtk).
  • Sur Win9X/ME
    • Editez le fichier C:\autoexec.bat. Rajoutez (à la fin du fichier, pour plus de précautions) la ligne suivante: SET PATH=%PATH%;ruby-install-dir\bin;gtk-install-dir\bin;gtk-install-dir\lib. Redémarrez la machine pour appliquer les modifications.
  • Sur WinNT/2000/XP/2003
    • Ouvrez le panneau de configuration > Système > Avancé > Variables d'environnements. Si il existe déjà une variable système nommée PATH, rajoutez simplement ceci à la fin de la variable: ruby-install-dir\bin;gtk-install-dir\bin;gtk-install-dir\lib. Si la variable n'existe pas, créez alors une nouvelle variable nommée PATH avec la valeur suivante: ruby-install-dir\bin;gtk-install-dir\bin;gtk-install-dir\lib.

Cinquième étape:

  • Il est maintenant temps de tester si tout fonctionne correctement. Ne vous inquietez pas si quelque chose ne va pas, il y a une section consacrée aux problèmes fréquemment rencontrés juste en dessous.
  • Les commandes suivantes doivent-être entrées dans une invite de commande MSDOS. Pour ouvrir l'invite de commandes:

    • Sur Win9X/ME
      • Cliquez sur le bouton Démarrer, et Exécuter. Entrez command et appuyez sur la touche <Entrée>.
    • Sur WinNT/2000/XP/2003
      • Cliquez sur le bouton Démarrer, et Exécuter. Entrez cmd et appuyez sur la touche <Entrée>.
    C:\>ruby -v
    ruby 1.8.0 (2003-05-26) [i386-mswin32]
    
    C:\>ruby -e "require 'gtk2'"
    
    C:\>ruby -e "require 'gtk2';Gtk::Window.new("Hello").show_all;Gtk.main"
  • Vous pouvez ignorer les avertissements (warnings) qui s'affichent dans l'invite de commandes. Ces avertissement ont été retirés de la version courante, et disparaitront automatiquement aussitôt que Masahiro Sakai sortira de nouveaux binaires pour Microsoft Windows.
  • Si aucune erreur ne s'est produite, l'installation s'est correctement déroulée. Vous pouvez donc directement commencer à lire un de nos tutoriels.

Problèmes fréquents

La variable d'environnement PATH

Vérifiez que la variable d'environnement PATH est correctement mise-à-jour. Pour se faire, entrez SET PATH dans l'invite de commandes, et vérifiez que la variable contient bien ruby-install-dir\bin;gtk-install-dir\bin;gtk-install-dir\lib comme expliqué au-dessus. Recommencez la quatrième étape si nécessaire. N'oubliez pas de redémarrer la machine sur Win9X/ME.

Voici le contenu de ma variable d'environnement PATH:

C:\>SET PATH
Path=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\dev\python;C:\j2sdk1.4.2\bin;C:\ruby\bin;C:\Gtk\bin;C:\Gtk\lib

Soyez prudent avec les répertoires dont le nom contient des espaces, ces derniers peuvent casser le nom du répertoire en question. Essayez dans ce cas d'enfermer le nom de ces répertoires dans des guillemets (par exemple: "C:\mon répertoire avec des espaces").

ruby -v
Si cette commande ne fonctionne pas, vérifiez que ruby-install-dir\bin figure bien dans votre variable PATH.
ruby -e "require 'gtk2'"

Si cette commande ne fonctionne pas, vérifiez que gtk-install-dir\bin et gtk-install-dir\lib figurent bien dans votre variable PATH.

Si vous obtenez toujours des erreurs, alors n'hésitez pas à nous contactez à travers une de nos listes de diffusion, en nous décrivant votre problème.

Auteur

  • Joao Pedrosa - joaopedrosa at yahoo dot com

Modifications

2003-09-08 Masahiro Sakai
Mise à jour pour Ruby-GNOME2 0.7.0
2003-06-05 Masao Mutoh
Changement du nom de la bibliothèque (Ruby-GTK en Ruby/GTK).
2003-06-04 Joao Pedrosa
Première version.

Traduction de la page anglaise par Laurent Sansonetti.

Dernière modification:2011/06/08 23:02:01
Mots clef:
Références:[compile_mingw] [Guides Installation]